Announcement

Collapse
No announcement yet.

my Basement

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • my Basement

    I have started to finish my basement in the house. I have poured walls, I took the pink foam insulation and put that up then i built my walls i put plastic inbetween the 2x4 wall and the foam insulation. And now i get like a condensation that comes down to the floor and builds puddles. What should I do to stop this so I can finsih the basement with carpet and not worry about the carpet getting wrecked? I only notice it during the winter. Thank you

    I aslo have a question on some windows i have in the house as well. I have a long eve that comes off the house and i have a some windows that have water that drips from the top of the window to the bottom of the window. I can not find any way that the water is getting into the top? Any suggestion's will be great. Thank you

  • #2
    Originally posted by TJ1962
    Have you read the foundation insulation PDF report which gives details on this subject?

    It is located at: http://www.basementquestions.com/fdninsulation.php

    This is a very large file. However, it is my experience that an air gap is necessary. Nothing should be touching walls. Then a dehumidifier should be used to draw damp air from the air gap.

    http://www.basementquestions.com/dehumidifiers.php

    It is difficult to say that the windows are leaking or moisture is building on inside of them due to air temperature. You could have the windows replaced and/or seal around them. Many single pain windows will develop humidity as well as frames can deteriorate. The dehumidifier will also help with this should it be just humidity.

    http://www.basementquestions.com/glassblockwin.php

    Hope this helps.....lots of info for insulation, dehumidifiers, window and basement finishing at BasementQuestions.com

    TJ1962
    Buddy the link you have given in your post is not working properly..!!
    I have tried to open it many times but got an error message of "page not available" everytime..!!
    I guess either I have slow internet connectivity or the link is dead..!!
    Last edited by TJ1962; 12-12-2011, 12:01 PM. Reason: ad link unauthorized

    Comment

    Working...
    X